2011/10/04

Solucionar puerto 80 ocupado luego de Webmatrix

Resolver esto me ha tomado un tiempo. Espero le resulte de ayuda a alguien.

Luego lo desinstalar Webmatrix (La versión 1.0 me parece, en Windows 7), encontré que XAMPP no podía usar el puerto 80 como antes.

Con la idea de averiguar qué proceso lo ocupa, ejecuto en la consola de comandos, como administrador:

netstat -anb

pero aparece que no hay información disponible sobre el proceso que ocupa el puerto 80.

Usando la utilidad tcpview (de Sysinternals), veo que el proceso es el mismo System, con PID 4.

Hago telnet localhost 80 y veo que quién está atendiendo es Microsoft-HTTPAPI/2.0

Reviso en el Panel de Control, Herramientas Administrativas, Servicios, y desactivo "Servicio Agente remoto para Microsoft Web Deploy 2.0."

Eso era. Al parecer un issue de Webmatrix. Ahora XAMPP ya puede iniciar en el puerto 80.

Referencias

17 comentarios:

  1. Me ha servido de mucha ayuda, instale Web Matrix y no me dejaba entrar a localhost con Apache...

    Muchas Gracias :)

    ResponderEliminar
  2. Anónimo10:08 p.m.

    muchas gracias me sirvio, lo que pasa es que normalmente uso XAMPP para un servidor apache y por razones de practica tuve que instalar iss y dejo de responder mi servidor apache a pesar de que a iss le asigne otro puerto, muchas gracias otra vez.

    ResponderEliminar
  3. Anónimo6:21 p.m.

    Gracias a mi también me sirvió :)

    ResponderEliminar
  4. Anónimo3:01 p.m.

    graciasssss, me salvaste!!!!

    ResponderEliminar
  5. Muchas gracias, esto estaba buscando, Instalé WebMatrix para probar ciertas cosas, y no pude seguir entrando al servidor Apache. Gran aporte. Muchas gracias de nuevo.

    ResponderEliminar
  6. Sí, es un problema ese efecto del WebMatrix.

    ResponderEliminar
  7. Anónimo4:41 p.m.

    haha gracias, ahora mas que nunca volví a odiar a microsoft XD

    ResponderEliminar
  8. PORFINNNN ALGUIEN QUE DIGA COMO ES LA VUELTA.... EXCELENTE TE DOY 5 PUNTOS

    ResponderEliminar
  9. Ok,pero solo funciona Apache,mas no MySQL :s se queda asi : "Attempting to start MySQL service..."

    ResponderEliminar
  10. Anónimo5:58 a.m.

    Muchas gracias, después de mirar en 50 páginas o más, por fin me has dado la solución.
    No tengo Webmatrix ni se lo que es, solo intenté instalar Ruby on rails, me petó y a partir de ahí el apache me daba el siguiente error:

    Port 80 in use by ""C:\Archivos de programa\IIS\Microsoft Web Deploy\MsDepSvc.exe"

    Gracias, por el aporte!

    ResponderEliminar
    Respuestas
    1. Me alegra. Que bueno que también fue de ayuda para ese caso. Gracias también por compartirlo.

      Eliminar
  11. Anónimo10:12 a.m.

    Muchas Gracias, bastante útil, estuve en una batalla hasta que encontré tu blog

    ResponderEliminar
  12. Anónimo2:39 a.m.

    En algunos casos este servicio no aparece en la lista, si es el caso de alguien, ejecutar CMD e ingresar estos comandos
    sc stop "MsDepSvc"
    sc config "MsDepSvc" start= disabled
    Espero k le sirva a alguien. Saludos. David

    ResponderEliminar
  13. Muchas gracias instale Webmatrix por que me parecieron interesantes algunas funciones, pero no me dejaba trabajar con wamp.

    ResponderEliminar

Más artículos